Support Line Disconnecting Callers

Incident Report for SmartRent

Resolved

This incident has been resolved.
Posted Jan 02, 2025 - 08:52 MST

Identified

We are working with our support provider to resolve this as quickly as possible. Please use our live chat support for now
Posted Jan 02, 2025 - 08:09 MST